Coopers Australian Lager Extract Problem?

Sat Dec 27, 2014 7:36 am

Hello,
I am new to home brew and basically i purchased a starter set for my old man (Woodforde Wherry) and got myself a starter set including Coopers Australian Lager. We brewed them together yesterday and have them currently at approximately 24 degrees celcius. I mixed kit as they said in instructions including adding 1kg of brewing sugar. But i have had this going for about 26 hours no and still have no bubbling or froth on top of wort. This is the case on Woodforde Wherry and the Coopers kit. Does this sound normal or have we done something incorrect? The start reading were 1.040 (Wherry) and 1.038 (Coopers)
Many thanks
Adam
tricey27
 
Posts: 1
Joined: Sat Dec 27, 2014 7:26 am

Re: Coopers Australian Lager Extract Problem?

Sat Dec 27, 2014 4:17 pm

Just give it another day. Sometimes the yeast doesnt' take off right away, particularly kit yeast. If it doesn't, get another packet of fresh dried yeast and rehydrate it in a half-liter of boiled then cooled (90F/32C) plain water.

HTH-
-B'Dawg
BJCP GM2 Judge
"Lunch Meat. It's an acquired taste....." -- Mylo
User avatar
BDawg
 
Posts: 5001
Joined: Tue Jul 31, 2007 5:27 pm
Location: North Bend, WA

Return to Extract & Partial Mash Brewing

Who is online

Users browsing this forum: No registered users

A BIT ABOUT US

The Brewing Network is a multimedia resource for brewers and beer lovers. Since 2005, we have been the leader in craft beer entertainment and information with live beer radio, podcasts, video, events and more.